l'Internet

Ainsi, vous pouvez configurer une liaison de jonction sur un commutateur géré

La connaissance du trunking ajoute beaucoup de valeur pour assurer la bonne performance de nos réseaux locaux. La fonction des trunks est essentielle, puisque leur mission principale est de faciliter l’inter-communication entre les différents VLAN, c’est-à-dire les réseaux locaux virtuels, mais aussi de partager ces VLAN avec d’autres commutateurs administrables que nous avons connectés au réseau net. Ce guide vous aidera à mieux comprendre ce qu’est la jonction, son fonctionnement et à appliquer les connaissances grâce à la configuration sur des appareils de fabricants populaires tels que Cisco et D-Link.

Qu’est-ce qu’un lien de jonction ou une jonction ?

C’est un lien qui est configuré dans un ou plusieurs ports d’un commutateur pour permettre le passage du trafic des différents VLAN que nous avons configurés. Ce lien peut fonctionner dans une connexion de switch vers un autre switch ou, d’un switch vers un routeur, et même d’un switch vers un serveur qui supporte la norme 802.1Q pour «passer» plusieurs VLAN simultanément. Dans les deux cas, son efficacité ne fait aucun doute, puisqu’elle évite d’avoir à utiliser un lien physique pour chaque VLAN.

Le protocole essentiel qui donne vie à la liaison trunk est celui qui appartient à la norme IEEE 802.1Q . Cela permet aux trames Ethernet de circuler sur le réseau avec une « balise » qui contient l’identifiant du VLAN (cette trame est appelée trame balisée).

Le processus d’ajout de l’ID de VLAN est appelé marquage de trame  . Rappelez-vous que lorsque nous parlons de trames, nous le faisons au niveau de la couche 2, c’est-à-dire au niveau de la liaison de données. Les informations trouvées dans la trame sont modifiées afin que les commutateurs impliqués puissent identifier à la fois les VLAN source et de destination. Cela permet au trafic de circuler en douceur entre eux.

Le processus de suppression de l’ID de VLAN s’appelle frame untagging . Ceci est fait lorsque le commutateur dispose d’un lien de type « accès », c’est-à-dire qu’il supprime la balise de la trame pour fournir la trame d’origine au PC, au serveur ou à l’équipement terminal qui ne « comprend pas » les VLAN balisés.

Configuration d’un lien de jonction sur les commutateurs Cisco

Nous avons opté pour cette marque car elle est l’une des plus utilisées lorsque nous apprenons les réseaux, puisque la certification typique Cisco CCNA est largement connue de tout administrateur réseau. De plus, il faut garder à l’esprit que Cisco dispose d’un outil tel que Cisco Packet Tracer pour effectuer des tests de configuration avec un simulateur.

L’image que nous avons partagée ci-dessus simule un petit réseau composé de deux ordinateurs et chacun d’eux est connecté à un commutateur. À leur tour, ces commutateurs sont connectés les uns aux autres. Ce scénario consiste en l’application d’un lien de jonction qui permet à deux ordinateurs dans le même VLAN de communiquer. Ces derniers, même s’ils sont connectés à des commutateurs différents.

Nous voyons maintenant le même exemple de réseau, mais avec les détails des ports utilisés. Généralement, pour la configuration de jonction, le dernier port de chaque commutateur est utilisé. Cependant, vous pouvez choisir le port que vous souhaitez, et toujours garder à l’esprit les ports que vous avez choisis, pour configurer correctement chacun d’eux.

La première étape consiste à configurer le VLAN sur chaque commutateur avec le même numéro d’identifiant et le même nom.

Au premier interrupteur :

SW1(config)#vlan 10
SW1(config-vlan)#name ejemplo
SW1(config-vlan)#exit

Sur le deuxième interrupteur :

SW2(config)#vlan 10
SW1(config-vlan)#name ejemplo
SW1(config-vlan)#exit

Pour vérifier la création de votre VLAN vous pouvez utiliser la commande suivante :

show vlan

Ou vous pouvez opter pour la commande abrégée :

sh vlan

Attendez-vous à voir ce qui suit sur la CLI de chaque commutateur :

10 ejemplos active Fa0/1
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

Dans la première ligne, nous pouvons voir notre numéro de VLAN 10 avec un exemple de nom . Il nous indique également qu’il est actif et qu’il est affecté à l’interface Fast Ethernet 0/1. Mais comment l’attribuer ?

Cette étape doit être répétée sur le port de chaque switch connecté aux ordinateurs :

SW1(config)#interface fa0/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 10

SW2(config)#interface fa0/1
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10

Maintenant, vous devez configurer le lien de jonction sur chacun des commutateurs. Vous devez configurer chacune des interfaces utilisées pour la connexion entre elles :

SW1(config)#interface fa0/24
SW1(config-if)#switchport mode trunk

SW2(config)#interface fa0/24
SW2(config-if)#switchport mode trunk

Important. Vous pouvez obtenir le message d’erreur suivant lorsque vous essayez d’affecter des interfaces en tant que troncs :

Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

Cela dépend de la marque et du modèle que vous utilisez, que ce message apparaisse ou non. Mais, vous n’avez pas à vous inquiéter. Ce message nous indique que l’encapsulation du backbone de l’interface n’est pas établie avec la norme IEEE 802.1Q que nous avons évoquée plus haut. Par conséquent, nous devons le corriger avec la commande suivante :

SW1(config-if)#switchport trunk encapsulation dot1q

Ensuite, les commandes pour établir les troncs seront les suivantes :

SW1(config)#interface fa0/24
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk

SW2(config)#interface fa0/24
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport mode trunk

Un autre aspect très important est que la commande «switchport mode trunk» permet d’effectuer une liaison de jonction de chacun des VLAN, mais tous les commutateurs permettent d’ajouter ou de supprimer les ID de VLAN de cette liaison de jonction. Pourquoi allons-nous passer un VLAN si nous n’allons pas vraiment l’utiliser sur l’autre switch ? Dans ces cas, nous pourrions utiliser la commande suivante : «switchport trunk allowed vlan 10» pour autoriser ce VLAN uniquement, car c’est beaucoup plus élégant que de ne pas passer tous les VLAN.

Enfin, il suffit d’attribuer les adresses IP à chaque ordinateur et il suffit de faire un ping pour vérifier que les deux ordinateurs peuvent communiquer correctement. C’est-à-dire que, selon l’exemple montré à partir de l’ordinateur avec IP 192.168.10.1, vous devez envoyer un ping à l’ordinateur avec IP 192.168.10.2. Si le ping est OK, tout va bien.

Configuration d’un lien de jonction sur les commutateurs D-Link

Tout ne sera pas Cisco dans le monde des réseaux, D-Link est l’un des meilleurs fabricants et possède les commutateurs les plus faciles à gérer dans leur portefeuille. D-Link nous permet de configurer des liaisons de jonction directement à partir d’une interface utilisateur graphique très intuitive, ci-dessous, vous pouvez voir à quel point il est facile de configurer une liaison de jonction dans un commutateur de ce fabricant.

Dans un switch D-Link DGS-1210-10MP, on peut aller directement dans le menu VLAN/VLAN 802.1Q, et choisir que les ports soient non étiquetés, étiquetés ou non membres. Dans ce cas, si l’on veut que les ports 1, 2, 3, 4, 9 et 10 soient en trunk, il suffit de les sélectionner tous en mode « taggé ». De cette façon, nous vous transmettrons un tronc de VLAN.

Le commutateur D-Link DXS-1210-10TS nous permet une plus grande configurabilité, dans ce cas, nous pouvons le configurer dans «L2 Features / VLAN Interface». Ici, nous pouvons le mettre en mode VLAN «Link», vérifier les trames entrantes si nous voulons qu’elles soient toujours étiquetées, non étiquetées ou les deux, et nous pouvons même définir un VLAN natif. Si nous voulons configurer uniquement les VLAN qui passent par le tronc, nous devrons sélectionner «Hybrid VLAN mode» et les ajouter manuellement.

Comme vous l’avez vu, la configuration d’un lien de jonction est assez simple, même si une série de recommandations doit être suivie lors de sa réalisation, et faites très attention aux ports sur lesquels nous la configurons.

Articles Similaires

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Botón volver arriba