Systèmes d'exploitation

Comment utiliser les plugins Pidgin dans Empathy Chat sous Linux

Empathy IM est une excellente application avec de nombreuses fonctionnalités. Cependant, il fait très défaut dans le département des modules complémentaires. Heureusement, il est facile de lancer Empathy en lui permettant de se charger dans les plugins Pidgin. Dans ce tutoriel, nous verrons à quel point il est facile d’activer les plugins Pidgin dans Empathy. L’utilisation de plugins avec cette application est rendue possible par le plugin Telepathy Haze.

Plugins Pidgin dans Empathy

Suivez les instructions ci-dessous pour savoir comment l’installer sur votre distribution Linux.

Ubuntu

Le plugin Telepathy Haze est dans les sources du logiciel Ubuntu et existe depuis un certain temps. Pour installer le pilote du plugin Purple (Pidgin IM) sur Ubuntu Linux, ouvrez une fenêtre de terminal et entrez la commande suivante:

sudo apt installer télépathie-brume

Debian

Debian a le plugin Telepathy Haze dans les sources du logiciel, bien qu’il puisse être plus ancien que les autres distributions Linux car Debian est plus lent à mettre à jour les paquets. Cela ne devrait pas affecter les plugins Pidgin, mais gardez cela à l’esprit.

sudo apt-get install telepathy-haze

Arch Linux

Arch Linux est toujours à jour, donc les utilisateurs pourront toujours obtenir la dernière version absolue de Telepathy Haze sur leur PC Linux. Installez-le avec Pacman:

sudo pacman -S télépathie-brume

Feutre

Fedora, comme Arch Linux, est assez récent et bénéficie de packages plus récents que la plupart des systèmes d’exploitation. Cela signifie que les fans de Fedora pourront installer la dernière version absolue de Telepathy Haze.

sudo dnf installer telepathy-haze

OpenSUSE

Selon la version d’OpenSUSE que vous utilisez, votre version de Telepathy Haze peut différer. Pour l’installer, ouvrez un terminal et entrez la commande suivante.

sudo zypper installer telepathy-haze

Construire à partir de la source

La télépathie est utilisée dans pratiquement toutes les distributions Linux, il ne devrait donc y avoir aucun problème à trouver un package pour cela. Ouvrez une fenêtre de terminal , recherchez «télépathie-brume» et installez-le. Sinon, suivez ces instructions pour créer le plug-in à partir de la source.

Tout d’abord, téléchargez la dernière version du code source.

curl https://telepathy.freedesktop.org/releases/telepathy-haze/telepathy-haze-0.8.0.tar.gz> telepathy-haze.tar.gz

À l’aide de la commande Tar , extrayez les fichiers de l’archive.

tar -xzvf telepathy-haze.tar.gz
cd télépathie-brume-0.8.0

En utilisant cat et d’ autres commandes, lisez les fichiers INSTALL et README inclus. Découvrez-les et découvrez les dépendances dont vous avez besoin. Recherchez également d’autres instructions décrites dans ces documents, telles que les paramètres du compilateur spécifiques à votre système d’exploitation, etc.

cat INSTALL | plus

cat README | plus

Exécutez ensuite le script de configuration et permettez-lui d’analyser et de configurer l’environnement de compilation de Telepathy Haze.

./configure

Configure analysera votre PC Linux pour les dépendances et les erreurs s’ils ne sont pas installés. Faites de votre mieux pour les installer. Vous devrez peut-être consulter pkgs.org pour voir les paquets.

Si tout semble bon, construisez et installez Telepathy Haze:

faire

sudo faire installer

Installation de Empathy IM

Après avoir installé Telepathy Haze, vous devrez installer l’application Empathy. Comme Telepathy Haze, il est très bien pris en charge, il ne devrait donc pas y avoir beaucoup de difficulté à l’installer.

Ubuntu

L’empathie est depuis longtemps incluse avec Ubuntu. Cependant, si votre installation ne l’a pas, son installation est aussi simple que:

sudo apt installer l'empathie

Debian

Debian est fourni avec Pidgin pour vos besoins de messagerie instantanée. Cela dit, Empathy peut être facilement installé via apt-get .

sudo apt-get install empathie

Arch Linux

Comme Telepathy Haze, les utilisateurs d’Arch peuvent obtenir la dernière version d’Empathy directement à partir des référentiels de logiciels. Installez-le via Pacman:

sudo pacman -S empathie

Feutre

Fedora a peut-être déjà installé Empathy, car il utilise de nombreux programmes Gnome. Cependant, si vous utilisez un autre bureau dans Fedora ou que vous ne trouvez pas Empathy, installez-le avec DNF:

sudo dnf installer l'empathie

OpenSUSE

Avez-vous besoin d’obtenir Empathy IM sur OpenSUSE? Prenez-le avec le gestionnaire de paquets Zypper:

sudo zypper installer l'empathie

Autre Linux

L’empathie est un vaste programme. En conséquence, le construire à partir de la source prend un certain temps. Heureusement, le projet Gnome dispose d’un guide détaillé qui montre exactement comment créer votre logiciel de messagerie instantanée. Rendez-vous sur cette page ici et suivez-la. Une fois que vous avez installé le client Empathy, revenez au guide pour savoir comment installer les plugins Pidgin sur Empathy.

Installer les plugins Pidgin dans Empathy

La meilleure partie de la possibilité d’utiliser les plugins Pidgin dans Empathy IM est le fait que les utilisateurs n’ont rien de spécial lors de l’installation. Au lieu de cela, suivez les instructions normales pour installer un plugin Pidgin, et Empathy trouvera le fichier et le téléchargera.

>> Remarque: les plugins Pidgin peuvent être trouvés ici .

Dans cet exemple, nous verrons comment installer le plugin RocketChat Pidgin. Tout d’abord, installez les dépendances correctes nécessaires pour créer le plugin.

Remarque: dans cet exemple, nous montrons les dépendances pour Ubuntu, Debian et Fedora. Pour plus d’informations sur les autres distributions, consultez le guide officiel .

Ubuntu / Debian

sudo apt installer libpurple-dev libjson-glib-dev libglib2.0-dev mercurial make libmarkdown2-dev

Feutre

sudo dnf installer libpurple-devel.x86_64 libmarkdown-devel.x86_64 json-glib-devel.x86_64 glib2.x86_64

À l’aide de l’ outil hg , téléchargez le code source du plugin RocketChat:

clone hg https://bitbucket.org/EionRobb/purple-rocketchat/

CD dans le dossier cloné purple-rocketchat sur votre PC et exécutez les commandes make et make install pour installer le plug.

cd violet-rocketchat

faire 

sudo faire installer

>> Si le plugin s’installe correctement et que Telepathy Haze fonctionne, vous devriez pouvoir voir RocketChat sous «Comptes» dans Empathy.

Articles Similaires

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Botón volver arriba